Показано с 1 по 3 из 3

Тема: Front (рабочие станции) не видят сервера Iiko

  1. #1
    Новичок
    Регистрация
    04.07.2012
    Адрес
    Moskow
    Сообщений
    17
    Поблагодарил(а)
    0
    Благодарностей: 0 (сообщений: 0)

    Front (рабочие станции) не видят сервера Iiko

    Добрый день.
    столкнулся вот с какой проблемой.
    Фронты не видят сервер.

    ниже история.
    10/07 в 11:00 у нас отвалилась лицензия (IikoCloud), только на возможность входа в IikoRMS Office. Созвонился с ТП, к 18:00 они подложили лицензию на 100 пользователей (по договору IikoCloud, до конца месяца, как должно было быть).
    После того как они отрапортовали, я обратил внимание что все точки, перестали видеть сервер. Плюс к этому, бухи стали звонить и сообщать что не могут подключиться к IikoOffice (нет соединения).
    Я залес на сервер и обнаружил, что в процессе подкладывания лицении, ТП зачем то поменяло порт с 8081 на 8083. (по дефаулту порт 8080, но у нас на сервере он уже занят другим процессом, по этому Айку повесили на 8081).
    снова позвонил в ТП, они некоторое время омахивались, ссылаясь на мои руки. Но после того, как я пригрозил позвонить их ген.диру и начать повествование с изначальной проблемы, плюс сколько они ее решали. Ребята из ТП согласились помочь. Они поменяли порт с 8083 на 8081.
    Но у меня ничего не заработало. Точки по прежнему не видят сервера и IikoOffice тоже.
    На просьбу проверить все ли верно у них настроено, они естественно сказали что, сервер наш, и ковыряйтесь сами. :-)

    Сервер пингуется из вне.
    на сервере 8081 порт открыт. только привязан он почему то к 0.0.0.0 (netstat -a).
    перезапуск служб и целиком сервера не помогает.

    Я этот сервер не поднимал и даже не админю его. (просто ситуация такая, что больше некому, в этом разбираться).

    Может кто сталкивался с такой проблемой?
    Что может быть? где искать камни. что проверять?
    Iiko 4.0, FIFO. (сеть из 40 объектов).

    SH_v_4.83. RK_v_7.4.21.144. Сервер справочником v_7.4.21.231. Server_2003.

  2. #2
    Сведущий
    Регистрация
    21.10.2013
    Адрес
    Россия
    Сообщений
    91
    Поблагодарил(а)
    7
    Благодарностей: 7 (сообщений: 5)
    Цитата Сообщение от DarthMuaddib Посмотреть сообщение
    Добрый день.
    столкнулся вот с какой проблемой.
    Фронты не видят сервер.

    ниже история.
    10/07 в 11:00 у нас отвалилась лицензия (IikoCloud), только на возможность входа в IikoRMS Office. Созвонился с ТП, к 18:00 они подложили лицензию на 100 пользователей (по договору IikoCloud, до конца месяца, как должно было быть).
    После того как они отрапортовали, я обратил внимание что все точки, перестали видеть сервер. Плюс к этому, бухи стали звонить и сообщать что не могут подключиться к IikoOffice (нет соединения).
    Я залес на сервер и обнаружил, что в процессе подкладывания лицении, ТП зачем то поменяло порт с 8081 на 8083. (по дефаулту порт 8080, но у нас на сервере он уже занят другим процессом, по этому Айку повесили на 8081).
    снова позвонил в ТП, они некоторое время омахивались, ссылаясь на мои руки. Но после того, как я пригрозил позвонить их ген.диру и начать повествование с изначальной проблемы, плюс сколько они ее решали. Ребята из ТП согласились помочь. Они поменяли порт с 8083 на 8081.
    Но у меня ничего не заработало. Точки по прежнему не видят сервера и IikoOffice тоже.
    На просьбу проверить все ли верно у них настроено, они естественно сказали что, сервер наш, и ковыряйтесь сами. :-)

    Сервер пингуется из вне.
    на сервере 8081 порт открыт. только привязан он почему то к 0.0.0.0 (netstat -a).
    перезапуск служб и целиком сервера не помогает.

    Я этот сервер не поднимал и даже не админю его. (просто ситуация такая, что больше некому, в этом разбираться).

    Может кто сталкивался с такой проблемой?
    Что может быть? где искать камни. что проверять?
    из вне по этоq строчке заходит? внешний айпишник:8081/resto

  3. #3
    Разбирающийся Аватар для Fishman
    Регистрация
    02.12.2014
    Адрес
    Кемерово
    Сообщений
    284
    Поблагодарил(а)
    10
    Благодарностей: 14 (сообщений: 10)
    1. Попробуйте проверить в настройках iikoFront конфигурационный файл который лежит %appdata%\iiko\CashServer\config.xml
    Откройте в текстовом документе(блокноте) и посмотрите строки
    <serverAddr>localhost</serverAddr> ------------это IP адрес вашего сервера
    <serverPort>8080</serverPort> ------------внешний порт
    2. в брайзере на кассе в адресной строке наберите http://localhost:8080/resto
    где localhost:8080 это IP адрес вашего сервера и внешний порт.
    Если связь есть должно открыться окно входа в систему.
    3. Проверить настройку проброса портов на роутере.

Похожие темы

  1. TCP.VPN. Кассы не видят друг друга
    от Rustam в разделе RK: Сервер
    Ответов: 15
    Последнее сообщение: 05.12.2013, 10:34
  2. Ответов: 12
    Последнее сообщение: 27.09.2012, 22:51
  3. Материнские платы - рабочие
    от skilful в разделе R-Keeper 6
    Ответов: 9
    Последнее сообщение: 25.07.2012, 19:03
  4. Ответов: 5
    Последнее сообщение: 24.11.2008, 12:33

Метки этой темы

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •